Hi need help I just added a panel to a dashboard o...
# support
Hi need help I just added a panel to a dashboard of mine on signoz, i think some error has happened because getting a full white screen. The following is a screenshot of the screen and the console log errors. How do i fix this? If someone could direct me on how to find code for the panels added to a dashboard, i could delete the panel i recently added and bring back this dashboard. Please direct me on how to find and delete panels of a dashboard through non gui means.
Hi @Sumanth Balaji, would it be possible to share the dashboard JSON? so that we can evaluate what is not right with it. cc @Srikanth Chekuri @Palash Gupta
@Prashant Shahi How do i get the dashboard json? im unable to open the dashboard, thats when the screen goes white
From the network tab
Copy code
"title": "429 Retry status codes hourly interval - Copy"
this is the panel i added last that caused the issue
@Prashant Shahi any guess on how to fix this?
@Prashant Shahi hey sorry but this is a bit urgent now, need to access the dashboard and its still problematic
not sure, how the invalid JSON got updated. Could be some edge case scenario from FE. cc @Palash Gupta
Meanwhile, you could save the payload in a file, and remove the newly added query section (whole
section) from the JSON. Followed by following
Copy code
curl '<http://localhost:3301/api/v1/dashboards/644e5f2f-015e-42d1-a560-d22687e54c99>' \
  -X 'PUT' \
  -H 'Authorization: Bearer BEARER-TOKEN-HERE' \
  -H 'Content-Type: application/json' \
  --data-binary @'./mydashboard.json'
with bearer token from any authenticated API calls in network tab.
@Sumanth Balaji can we hop on a call to resolve this issue? That would be easier. I am available anytime other than 110011:30 and 12301:30pm.
tried the above put api call, keep facing the error message
Copy code
{"status":"error","data":"Error reading request body","errorType":"bad_data","error":"title not found in post data"}%
i tried modifying the original payload by removing the unwanted dashboards and also removing "success" field and removing "data" key and opening up the object, still facing same error message