Hi Team, I tried installing Signoz on Kubernetes. ...
# support
Hi Team, I tried installing Signoz on Kubernetes. For the chi-my-release-clickhouse-cluster-0-0-0 pod I am getting the following error : Events: Type Reason Age From Message ---- ------ ---- ---- ------- Normal Scheduled 58m default-scheduler Successfully assigned platform/chi-my-release-clickhouse-cluster-0-0-0 to nroy-virtual-machine Normal Pulled 58m kubelet Container image "docker.io/busybox:1.35" already present on machine Normal Created 57m kubelet Created container my-release-clickhouse-init Normal Started 57m kubelet Started container my-release-clickhouse-init Normal Pulling 49m (x4 over 57m) kubelet Pulling image "docker.io/clickhouse/clickhouse-server:22.8.8-alpine" Warning Failed 47m (x4 over 55m) kubelet Error: ErrImagePull Warning Failed 47m (x6 over 55m) kubelet Error: ImagePullBackOff Warning Failed 11m (x10 over 55m) kubelet Failed to pull image "docker.io/clickhouse/clickhouse-server:22.8.8-alpine": rpc error: code = Unknown desc = context deadline exceeded Normal BackOff 2m53s (x133 over 55m) kubelet Back-off pulling image "docker.io/clickhouse/clickhouse-server:22.8.8-alpine" has anybody faced the same error while installing on Kubernetes thru helm...
Issue seems to be with pulling clickhouse image from DockerHub. https://hub.docker.com/layers/clickhouse/clickhouse-server/22.8.8-alpine/images/sha2[…]c13ef3b28d436e19a9f916d6a1ef1a68e77b045869a00?context=explore ^ You can see that the image tag is publicly available.
This is issue with your k8s cluster facing issue with pulling images. Unfortunately, I cannot pin on what could cause this.
I am unable to reproduce it on my local
@Prashant Shahi you are right . I created a new cluster and was able to run all the pods ..Thanks !
@Nilanjan Roy glad to know that the issue is resolved with the new cluster 🙂