https://signoz.io logo
#support
Title
# support
p

Pishang Ujeniya

11/23/2023, 1:38 AM
After installing I am getting this error in init container. I tried following other ways to install it. 1. Tried installing via signoz helm repo, as per mentioned in docs. 2. Tried installing from the Zip from GitHub releases of charts
signoz-0.30.2.tgz
3. Tried installing by converting
tgz
to
yaml
template and applying it manually using the command
helm template signoz-app ./signoz-0.30.2.tgz --namespace signoz-platform --create-namespace --include-crds > ./signoz.v0.30.2.yaml
Please someone help me. Even the link mentioned in the error message is also not working, so I guess that is the reason. (Attached screenshot in thread)
The issue relates to the file serving from GitHub sources.
I guess the issue is specially for my chrome, edge browser and in the USA server's network, because I am able to download the raw file using the same link in Tor Browser & Chrome browser of mobile.
The issue is not in server, because server network can download the file successfully, only the Kubernetes init container is not able to download the file. Don't know why 😢 .
I tried to manually execute the same command inside the shell of the container, and its confirmed that it is failing inside it.
Seems like some network issue within the container. Because, even ping fails to resolve the IP for google.com & github.com
I found the solution. My Kubernetes was having such warning on clickhouse pod.
Copy code
Nameserver limits were exceeded, some nameservers have been omitted, the applied nameserver line is: 6X.XX.XX.2XX 66.XX.XXX.21X 6X.XX.XX.5X
I removed redundant DNS nameservers from
/etc/resolve.conf
and only kept the following content in that file
Copy code
nameserver 1.1.1.1
nameserver 8.8.8.8
And Restarted the cluster. It solved. 🎉
p

Pranay

11/23/2023, 1:07 PM
Awesome, @Pishang Ujeniya - Great to see that this was solved 🙂