Hello! I have some doubt about Alert Channels to S...
# support
Hello! I have some doubt about Alert Channels to Slack. I am running signoz on K8s installed with helm chart. 1 - Who are the pod that send the request to hooks.slack.com ? Is the front end or query-service? 2 - I think my problem is because we need to use proxy here to request outside internet. I configured this envrionments on my front-end pod . And after i make a curl post direct from frontend pod shell and works well on hooks.slack.com.
Copy code
              value: "<http://myproxy>"
            - name: HTTP_PROXY
              value: "<http://myproxy>"
But using the signoz UI the slack test still dont working. Looking for logs i see a request sended to query service. So after, i put the same envs HTTPS_PROXY and HTTP_PROXY on query-service pod. And strange, after this the front-end UI page alert channels become give only 500 error. I cant save anymore the configs. See the images on below the error after i configure proxys envs on query service pod. Resume: The notification using slack channel dont works here.
it's the
which finally integrates to slack, webhook etc. The query-service calls the alertmanager internally
Can you the logs from alertmanager?
@Amol Umbark can you please drill deeper into the issue?
I’m open for a call if need. Thanks
@Paulo Henrique de Morais Santiago at the moment we don't natively support http proxy through channel config (please feel free to create an issue for support of proxy). but you are right about setting env variables to achieve this. can you try setting the env vars for alert manager pod.
@Amol Umbark Thanks for response bro. I open the issue https://github.com/SigNoz/signoz/issues/2025#issuecomment-1379424121
Im making some new trys with NO_PROXY config, without success yet. But if i get i back you here.
You think the only pod that need proxys configs is alert manager?
yes. Only alert manager connects with third parties like slack. did you try with http proxy env var, does it work?
@Amol Umbark I tryed without success,
I try use this proxy_url, on alertmanager.yml config file. And no success too. https://prometheus.io/docs/alerting/latest/configuration/#http_config
Like this example: https://github.com/prometheus/alertmanager/blob/main/config/testdata/conf.good.yml I think the alert-manager dont user the environment from linux host to proxy.
I create a VM and try to use Docker instead kubernetes. And i have the same problem.
let me check and get back.
@Paulo Henrique de Morais Santiago I looked into this. We will have to change alert manager to handle proxy server. We will resolve the issue soon. Please follow the issue for further updates. https://github.com/SigNoz/signoz/issues/2025#issuecomment-1379424121