https://signoz.io logo
#support
Title
# support
z

Zishan Shaikh

05/02/2022, 6:53 PM
Hi #support, need help with filtering based on http headers, i am looking to filter the traces based on a http header e.g. nonce or any other header, how do i do this with Signoz, this is a Spring Boot service, i am making a REST API call with nonce as 123 in the header, unable to filter it here based on the header ?
p

Pranay

05/03/2022, 1:59 AM
@Zishan Shaikh Which version are you on? We have made lots of improvement in trace filtering and recommend you update to the latest version New versions have some filters on left side and also way to filter based on tags. More details here - https://signoz.io/docs/userguide/traces/#open-the-traces-section
z

Zishan Shaikh

05/04/2022, 6:20 PM
Hi @Pranay I have tested with latest version of signoz 0.7.5, i am unable to filter based on the required header, in this case its a custom header "nonce", i am unable to see this header in the list of tags, neither i am able to add a new tag, as the UI does not allow me to type anything in the tags
p

Pranay

05/05/2022, 12:54 AM
@Zishan Shaikh I see. Are you sending the custome header "nonce" as a tag in your traces? If you are sending the custom header as a
tag
it should be available in the tag dropdown as shown in the screenshot below. Can you share how are you currently passing this tag to your traces? And the exact tag you are sending
z

Zishan Shaikh

05/09/2022, 12:16 PM
@Pranay #support i am sending "nonce" as a http header e.g. nonce = <some random UUID>, I am making a call to a REST API e.g. /users and passing nonce as part of request header, this nonce is sent with every request, this helps me for internal reference as a correlation id, nonce will be unique for every request, i want this header to be listed under tags, so that i can filter based on the nonce value, i want to be able to filter based on particular nonce value, how do i get this header listed in the tags list, also how do i send header "nonce" as a tag in the traces ?
s

Srikanth Chekuri

05/10/2022, 2:45 AM
@Zishan Shaikh . You need to enabled capturing request/response headers using the java-agent. https://opentelemetry.io/docs/instrumentation/java/automatic/agent-config/#capturing-http-request-and-response-headers. If your enable it and make sure the instrumentation is sending data to signoz you can then filter nonce or any other header
z

Zishan Shaikh

05/10/2022, 4:39 AM
@Srikanth Chekuri I had tried this earlier with no luck, let me try this again and get back.
p

Pranay

05/22/2022, 3:13 PM
@Zishan Shaikh just checking in - was this solved or you are still facing this issue?
2 Views