Hi! I just started integrating SigNoz in our appli...
# support
Hi! I just started integrating SigNoz in our application, backend integration for golang & java based services worked smoothly, but facing issue with angular inteceptor for opentelemetry. It is showing connection reset error. Any direction to solve this would be highly appreciated.
using the following library for integration: https://github.com/jufab/opentelemetry-angular-interceptor
tried with config
Copy code
otelcolConfig: {
      url: '<http://ip:4317/v1/traces>'
also tried with http://ip:4317 as well.
Are you trying to monitor the frontend built in angular @User?
trying to check if end to end traces are possible
we have micro services running in golang and java, there we just gave direct ip:4317, it worked smooth, but here we are giving http://, do we need to enable any specific receiver for this ? @User.
PS: I am a newbie to the APM world.
Can you please post exact error? @User
we tried with 4317, which is actually grpc receiver, but mentioned library is using http, so we tried with http receiver runnning in 55681, now we are getting this error.
below one came when we tried with port 4317 grpc receiver.
Can you please expand the connection reset error?
here is the stacktrace for the same
@User port
is for otlp grpc and
is the new port for otlp http and port
is the legacy port for otlp http. You would need to use port
for your cases. But before that, you need to expose the ports at docker-compose file at https://github.com/SigNoz/signoz/blob/develop/deploy/docker/clickhouse-setup/docker-compose.yaml#L60. It should be like
Copy code
      - "4317:4317"       # OTLP GRPC receiver
      - "4318:4318"       # OTLP http receiver
      - "55681:55681"     # OTLP legacy http receiver
after restarting otel-collector, confirm whether ports are correctly exposed by
sudo docker ps
as in below screenshot. The otel-collector line should be containing>4318/tcp
@User: I have used default configuration for docker swarm. this is the configuration it has
Copy code
    image: signoz/otelcontribcol:0.4.0
    command: ["--config=/etc/otel-collector-config.yaml", "--mem-ballast-size-mib=2000"]
      - ./otel-collector-config.yaml:/etc/otel-collector-config.yaml
      - "1777:1777"   # pprof extension
      - "8887:8888"   # Prometheus metrics exposed by the agent
      - "14268:14268"       # Jaeger receiver
      - "55678"       # OpenCensus receiver
      - "55680:55680"       # OTLP HTTP/2.0 legacy port
      - "55681:55681"       # OTLP HTTP/1.0 receiver
      - "4317:4317"       # OTLP GRPC receiver
      - "55679:55679" # zpages extension
      - "13133"       # health_check
apart from that, there is some inconsistency for otel-collector. because without any changes to config, with same compose file, every update of stack gave us a different error
once it was connection reset, then it was not implemented error, after that cors error and finally it worked.
unable find the rootcause for the same.
ohk. docker-swarm is working on a very old version. There would be many backend and UI changes. Let us version bump the docker-swarm setup and will notify you again. As, I remember with the otel-collector version in docker-swarm setup
setting was not available.
@User: here are the versions we got from dockerswarm.
Copy code
vm8pgjfk6jxo   signoz_clickhouse                   replicated   1/1        yandex/clickhouse-server:latest   *:8123->8123/tcp, *:9001->9000/tcp
ivef4tb240rc   signoz_frontend                     replicated   1/1        signoz/frontend:0.4.1             *:3301->3301/tcp
dzoksjk6w6w6   signoz_otel-collector               replicated   3/3        signoz/otelcontribcol:0.4.0       *:1777->1777/tcp, *:4317->4317/tcp, *:8887->8888/tcp, *:14268->14268/tcp, *:30000->13133/tcp, *:30001->55678/tcp, *:55679-55681->55679-55681/tcp
d2ksffqec97m   signoz_otel-collector-hostmetrics   replicated   1/1        signoz/otelcontribcol:0.4.0       
b0f9ehe75bdb   signoz_query-service                replicated   1/1        signoz/query-service:0.4.1        *:8080->8080/tcp
can you help us with the latest versions ? we shall update and try it out.
@User manual update of images to latest did not work, for many actions in ui, it is showing “something went wrong”
@User It probably would need some more tweaking. You can go through the `docker-compose` v2 yaml line by line and make relevant changes if urgent. @User would be the guy to version bump docker-swarm setup. Should be done by EOD or tomorrow.