Hello, I'm having a problem. I installed the Helm ...
# support
i
Hello, I'm having a problem. I installed the Helm template in the platform namespace. However, pods in the platform namespace can't reach the kube-dns service. This prevents me from exporting metrics/logs/traces to the Signoz Otel Collector because the service isn't registered in DNS. I've tried a few things to resolve this, including adding a service to the platform namespace, but I still can't resolve DNS requests. More details here
So, that wasn't a real problem by default. You can't resolve services that are in another namespace. I wasn't able to allow resolution of service IPs outside of the current namespace. Therefore, I just placed SigNoz in the same namespace as my services. However, now I have another problem regarding sending metrics and other data to the OpenTelemetry Collector. My Java services don't use a Eureka server. But it seems like the OpenTelemetry agent might require one?
Copy code
org.springframework.web.client.ResourceAccessException: I/O error on GET request for "<http://localhost:8761/eureka/apps/>": Connect to <http://localhost:8761> [localhost/127.0.0.1, localhost/0:0:0:0:0:0 ā”‚
ā”‚     at org.springframework.web.client.RestTemplate.createResourceAccessException(RestTemplate.java:905) ~[spring-web-6.1.1.jar!/:6.1.1]
A little bit further in the logs, I have another error that repeats. I also tried port 4318, but that didn't solve any of these issues.
Copy code
[otel.javaagent 2024-07-09 13:20:11:390 +0000] [OkHttp <http://my-release-signoz-otel-collector:4317/...>] ERROR io.opentelemetry.exporter.internal.http.HttpExporter - Failed to export logs. The request could not be executed. Full error message: Connection reset