Hi. I followed the steps about log pipelines from ...
# support
n
Hi. I followed the steps about log pipelines from here and am stuck. 1. I have used the "Json parser" and moved the
body
into a
attributes.temp
Then I "move"
attributes.temp.context
to
attributes.context
Note that
attributes.context
is a JSON field. Signoz doesn't recognise this as a JSON field and still shows it in a string format (shows "Data type: String"). Is there a way to force this field's recognition as JSON and get all the "filter for/out" options for it? 2. Is there a way to remove "body" from the default log ui? This is because I just want to mimic datadog and just show the
body.message
field.
n
1. Yeah right now, attributes only support string/int/float/bool and not nested types. You can flatten them out to the top level if you want. 2. you can move anttribute in this case,
attributes.temp.message
to
body