Hi there! Can someone please let me know what I'm...
# support
d
Hi there! Can someone please let me know what I'm missing? I can't expose SigNoz deployed in EKS with ingress enabled. I cloned this repo - https://github.com/SigNoz/charts enabled ingress for the front end and set the
tls
with the hosts.
p
Hi @Datos, can you share your override config?
Provided you have set up your cluster issuer, ingress controller and domain DNS correctly, the following config should do the job:
Copy code
frontend:
  ingress:
    enabled: true
    annotations:
      cert-manager.io/cluster-issuer: letsencrypt-prod
    className: nginx
    hosts:
      - host: signoz.domain.com
        paths:
          - path: /
            pathType: ImplementationSpecific
            port: 3301
    tls:
      - secretName: signoz.domain.com-tls
        hosts:
          - signoz.domain.com
For detailed instruction, refer to our docs: https://signoz.io/docs/tutorial/setting-up-tls-for-signoz/
d
Many thanks @Prashant Shahi! I later found this document. It's working for me now.