Hi Team! Is there a possibility for Trace Explore...
# support
k
Hi Team! Is there a possibility for Trace Explorer to display only the initial span of each trace? Currently, it exhibits all spans for a given trace, making it challenging to locate a specific trace. Basically, I want Trace Explorer to show only traces in the result (and not spans)
Please let me know if you need any of our configuration files.
@nitya-signoz @Chitransh Gupta @Vishal Sharma can you please help us?
n
Click on the traces tab near list view?
v
Also @Kashyap Rajendra Kathrani you can also add filter
parentSpanId=''
in list view
k
Thank you! @nitya-signoz and @Vishal Sharma both of your solution worked. For me, "Root Operation Name" is not showing up the endpoint path (/partners/v2/attendance) along with the HTTP Method (POST) How can I make sure it also has http route along with the http method?
@nitya-signoz @Vishal Sharma can you please help here?
Hi @nitya-signoz @Vishal Sharma can you please help here? We are not getting HTTP Route under "Root Operation Name"
v
It depends on the instrumentation, which language are you using?
k
@Vishal Sharma Somehow httpRoute is coming as null We are using Node Auto Instrumentations package for Instrumenation Language - Typescript Framework - Nestjs Our tracer.ts file is as follows
Copy code
import { OTLPTraceExporter } from '@opentelemetry/exporter-trace-otlp-http';
import { Resource } from '@opentelemetry/resources';
import * as opentelemetry from '@opentelemetry/sdk-node';
import { SemanticResourceAttributes } from '@opentelemetry/semantic-conventions';
import getEnv from './shared/utils/get-env';
import { getNodeAutoInstrumentations } from '@opentelemetry/auto-instrumentations-node';
import { TypeormInstrumentation } from 'opentelemetry-instrumentation-typeorm';
import * as dotenv from 'dotenv';
dotenv.config();


const exporterOptions = {
  url: getEnv<string>('SIGNOZ_OTEL_COLLECTOR'),
};

const autoInstrumentationsOptions = {
  '@opentelemetry/instrumentation-fs': { enabled: false },
  '@opentelemetry/instrumentation-dns': { enabled: false },
  '@opentelemetry/instrumentation-amqplib': { enabled: false },
  '@opentelemetry/instrumentation-aws-lambda': { enabled: false },
  '@opentelemetry/instrumentation-aws-sdk': { enabled: true },
  '@opentelemetry/instrumentation-bunyan': { enabled: false },
  '@opentelemetry/instrumentation-cassandra-driver': { enabled: false },
  '@opentelemetry/instrumentation-connect': { enabled: false },
  '@opentelemetry/instrumentation-cucumber': { enabled: false },
  '@opentelemetry/instrumentation-dataloader': { enabled: false },
  '@opentelemetry/instrumentation-express': { enabled: false },
  '@opentelemetry/instrumentation-fastify': { enabled: false },
  '@opentelemetry/instrumentation-generic-pool': { enabled: false },
  '@opentelemetry/instrumentation-graphql': { enabled: false },
  '@opentelemetry/instrumentation-grpc': { enabled: true },
  '@opentelemetry/instrumentation-hapi': { enabled: false },
  '@opentelemetry/instrumentation-http': { enabled: true },
  '@opentelemetry/instrumentation-ioredis': { enabled: true },
  '@opentelemetry/instrumentation-knex': { enabled: false },
  '@opentelemetry/instrumentation-koa': { enabled: false },
  '@opentelemetry/instrumentation-lru-memoizer': { enabled: false },
  '@opentelemetry/instrumentation-memcached': { enabled: false },
  '@opentelemetry/instrumentation-mongodb': { enabled: false },
  '@opentelemetry/instrumentation-mongoose': { enabled: false },
  '@opentelemetry/instrumentation-mysql2': { enabled: false },
  '@opentelemetry/instrumentation-mysql': { enabled: false },
  '@opentelemetry/instrumentation-nestjs-core': { enabled: true },
  '@opentelemetry/instrumentation-net': { enabled: false },
  '@opentelemetry/instrumentation-pg': { enabled: true },
  '@opentelemetry/instrumentation-pino': { enabled: true },
  '@opentelemetry/instrumentation-redis': { enabled: true },
  '@opentelemetry/instrumentation-redis-4': { enabled: false },
  '@opentelemetry/instrumentation-restify': { enabled: false },
  '@opentelemetry/instrumentation-router': { enabled: false },
  '@opentelemetry/instrumentation-socket.io': { enabled: false },
  '@opentelemetry/instrumentation-tedious': { enabled: false },
  '@opentelemetry/instrumentation-winston': { enabled: false },
};

const traceExporter = new OTLPTraceExporter(exporterOptions);
const sdk = new opentelemetry.NodeSDK({
  traceExporter,
  instrumentations: [getNodeAutoInstrumentations(autoInstrumentationsOptions), new TypeormInstrumentation()],
  resource: new Resource({
    [SemanticResourceAttributes.SERVICE_NAME]: getEnv<string>('SERVICE_NAME'),
  }),
});

sdk.start();

process.on('SIGTERM', () => {
  sdk
    .shutdown()
    .then(() => console.log('Tracing terminated'))
    .catch(error => console.log('Error terminating tracing', error))
    .finally(() => process.exit(0));
});
export default sdk;
We have ensured that opentel gets initialised before creating nest app Please let me know if you need more details.
Hi @Vishal Sharma Can you please help us here?