Setting the retention periods fails in the latest ...
# support
t
Setting the retention periods fails in the latest signoz. How to fix that?
p
Can you "temporarily" increasing the ClickHouse instance resource and try setting the TTL?
Updating TTL is a resource intensive operation.
t
Which resource? Disk space? There was enough disk space when I tried, but it failed and now I have run out of it.
Why? Isn’t it just deleting data older than the TTL?
Can I manually clear the clickhouse data while keeping all settings/configured dashboards?
p
are you using SigNoz in Docker Standalone or Kubernetes?
t
Docker standalone
p
Run the following to clear data of clickhouse and zookeeper:
Copy code
make clear-standalone-ch
make sure to bring down the signoz cluster first, followed by clean up, then back up.
t
Thanks I will try that. This will not delete users and other settings, right? 🙂
Related question: when transferring a Docker standalone instance to a new server, how do I backup/restore settings in an ideal way? Or simply move everything including volumes?
p
This will not delete users and other settings, right?
it will not. They are stored in SQLite DB file.
We do not have official guidelines on the backup/restore yet. For Docker Standalone, copying
data
folder from
deploy/docker/clickhouse-setup/data
should work fine.