Hi, trying to deploy SigNoz using Helm into one of...
# support
t
Hi, trying to deploy SigNoz using Helm into one of our Kuberentes EKS clusters. All egress traffic must run through a HTTP proxy. I cannot see a way (in the Helm chart values) to configure any proxy configurations? For example, one of the pods is failing (signoz-clickhouse-udf-init) due to it not being able to wget a histogramQuantile file from GitHub. Is there a way to configure a proxy either directly or via ENV vars? Thanks.
a
@Prashant Shahi
p
Hi @Tom Williams 👋 Currently, it is not possible to modify the init-container command. I will be working on this today. For time-being, you can set
clickhouse.initContainers.udf.enabled
to
false
. Everything in SigNoz should work fine except for Histogram Functions of Query-Builder.
t
Many thanks @Prashant Shahi I will go ahead and disable for the time being.