https://signoz.io logo
#support
Title
# support
w

Willy Loos

09/15/2023, 2:14 PM
Hi, i'm having difficulty reaching the otel collector running in docker-compose, from my app which is running in another docker compose. I can create traces from a basic app on bare metal, but not from docker-compose. I've tried several things like this:
Copy code
extra_hosts:
  - host.docker.internal:host-gateway
environment:
	OTEL_EXPORTER_OTLP_INSECURE: "True"
	OTEL_EXPORTER_OTLP_ENDPOINT: "host.docker.internal:4317"
Using `OTEL_EXPORTER_OTLP_ENDPOINT: "otel-collector:4317"`will give me error notices, but when i use `extra_hosts:`there are no traces but nu error messages either. The signals just seem to disappear. Is there some other host or DNS that should connect to? (this is on linux) I also tried adding signoz and my app to the same docker compose network. That should normally work, but the signoz compose structure is pretty complex. It seems like there is more than meets the eye concerning networking. Please tell me how to connect from another docker compose application.
I've finally found it, it's this: We're using FastAPI and the uvicorn process should be started without the
--reload
option.
First found it in the SigNoz docs.. and the problem isn't even in SigNoz. https://signoz.io/docs/instrumentation/fastapi/ After looking closer, also found it in the Opentelemetry docs: https://opentelemetry.io/docs/instrumentation/python/automatic/example/#instrumentation-while-debugging
bye now, keep up the good work 👋
2 Views