Hi! I tried to install Signoz on EKS using Helm an...
# support
Hi! I tried to install Signoz on EKS using Helm and
, and
all encountered the same error:
Error creating clickhouse client: code: 516, message: admin: Authentication failed: password is incorrect or there is no user with such name
I have checked the credentials in the pod env for all pods and they are correct Environment: • EKS Cluster:
• Chart Version:
I tried setting up the same Helm chart on Docker Desktop cluster, everything works fine. Anyone knows how to solve the issue?
Hello @Chatthana (Aom) Janethanakarn 👋 That error happens when the credentials passed to those components are not valid. Are you using external clickhouse or SigNoz-managed clickhouse?
We haven't tested in EKS v1.25 and v1.26 yet. will test it out and let you know.
I did not use external Clickhouse. Just use the one bundled with the official Helm Chart. To provide more information, my Docker Desktop is running on 1.25 so I am trying on EKS 1.25. Will let you know whether it works. Thank you very much!
Already found the solution. It was because of the pod ip range is not in
Once I updated, it works. Thank you for your support.