https://signoz.io logo
#general
Title
# general
j

Jose Infazon

03/26/2023, 4:02 PM
Hi everyone, I'm struggling withe setting the trace retention days. I've changed it to 5 days, but several days have passed and the setting never persisted. I've tried recreating the docker container, restarting, etc. But still the issue:
Is there a way to force this? Or Delete all data and restart?
I'm running signoz on an ec2 instance (t3a.2xlarge)
v

Vishal Sharma

03/27/2023, 4:21 AM
Which SigNoz version are you using @Jose Infazon? In latest version there are some improvements on retention.
j

Jose Infazon

03/27/2023, 11:27 AM
0.17.0, the latest one. I've even block all incoming traffic so as not to have new traces and process the remaining one....still kept in that loop
v

Vishal Sharma

03/29/2023, 5:02 AM
You can connect to SQLite DB and clear TTL status table to allow updating retention setting. If you are using docker follow below steps: Connect to query-service
Copy code
docker exec -it query-service sh
Run the following:
Copy code
# install sqlite
apk update
apk add sqlite

# open sqlite with signoz.db
sqlite3 /var/lib/signoz/signoz.db

# (sqlite shell) check existing ttl status
select * from ttl_status;

# delete all rows of ttl_status
DELETE FROM ttl_status;
6 Views